Mal wieder… Vertrauensstellung zur Domäne verloren

Auch dieses Problem gehört zum Alltag eines Microsoft Admin. Der Benutzer ruft an und kann sich nicht anmelden. Das System meldet sich mit der Fehlermeldung „Die Vertrauensstellung zwischen dieser Arbeitsstation und der primären Domäne konnte nicht hergestellt werden“. Ursachen hierfür gibt es leider viele. Manchmal hat das System die Domäne zu lange nicht gesehen, Kerberos oder Zeitprobleme sind ebenfalls nicht selten. Aber auch eine defekte Netzwerkkarte hat in meiner Praxis schon einmal zu diesem Phänomen geführt.

Das erste Problem was wir jetzt haben ist wie ich mich wieder am System anmelden kann.

Das geht einmal über die lokale Anmeldung da diese Anmeldedaten in der lokalen Kontendatenbank gespeichert sind. Wer diese Daten nicht zur Hand hat kann einen kleinen Trick nutzen und einfach das Netzwerkkabel ziehen. Dann versucht sich der Domänenclient nicht am AD neu zu authentifizieren sondern nutzt, solange nicht via Gruppenrichtlinien ausgeschalten, die lokal zwischengespeicherten Anmeldedaten der Domäne.

Sobald die Anmeldung erfolgt ist bleiben wieder zwei Möglichkeiten zur Auswahl. Möglichkeit 1 ist dann eher der bekannte Klassiker. Einfach über die Systemeigenschaften kurz aus der Domäne zur Arbeitsgruppe wechseln und ohne Neustart gleich wieder in die Domäne. Das ganze funktioniert standardmäßig auch ohne Administrative Rechte.

Möglichkeit 2 dagegen ist etwas neuer und funktioniert via PowerShell. Mit dem Cmdlet:

Hier sieht man schon durch das Ergebnis FALSE das die Verbind verloren gegangen ist. Setzt man den Schalter -REPAIR wird die Verbindung wieder hergestellt.

Jetzt noch ein Neustart und alles geht wieder.

Das ganze funktioniert ab Windows 7 bzw. Windows Server 2008 R2 und ist einfach der schönere Weg.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.